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DSP I: ELEC 3523

Assembly Programming Lab

Skills

This laboratory deals with developing and running an assembly program on the TMS320C6701 EVM using Code Composer Studio (CCS) v2.0.  It will also help you become more familiar with the features of the TMS320C6701 assembly language. By the end of the laboratory you will be able to:

· Create a project in CCS

· Build an assembly language program

· Run an assembly language program on the TMS320C6701 EVM

You will be familiar with TMS320C6701:

· addressing modes

· parallel instructions

· conditional operations

· delay slots

· register file cross paths

Reading

· SPRU198: TMS320C6000 Programmer's Guide

· Structure of Assembly Code (chapter)

· SPRU305: TMS320C6201/6701 Evaluation Module Technical Reference

· TMS320C6x EVM DSP Memory Map (MAP 0) (table)
· TMS320C6x EVM DSP Memory Map (MAP 1) (table)
· SPRU186: TMS320C6000 Assembly Language Tools User's Guide 

· Sections (section)
· How the Assembler Handles Sections (section)
· How the Linker Handles Sections (section)
· Linker Command Files (section)
· The MEMORY Directive (section)
· The SECTIONS Directive (section)
· Assembler Directives (chapter)
· SPRU189: TMS320C6000 CPU and Instruction Set Reference Guide

· TMS320C62x/C64x/C67x Fixed-Point Instruction Set (chapter)
· TMS320C62x/C64x/C67x Floating-Point Instruction Set (chapter)
· See sections titled "Individual Instruction Descriptions" for information on instructions

· SPRU509: Code Composer Studio Getting Started Guide
· Code Composer StudioProject Management and Editing Tools (chapter)

Description

In this lab you will be writing some general assembly language code and also some optimized assembly code.  The optimization you will be doing will be very basic and will simply use features of the TMS320C6701 that will help the code run faster.

The following diagram shows the internal sections of the 'C6x DSP.  In the DSP there is separate program memory and data memory and a central core with two data paths. 
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Figure 1: TMS320C6201/TMS320C6701 Block Diagram, taken from SPRU190: TMS320C6000 Peripheral Reference Guide
Instructions

Below is the structure of a line of assembly code.

	Label:
	Parallel bars (||)
	[Condition]
	Instruction
	Unit
	Operands
	;Comments


Labels identify a line of code or a variable and represent a memory address that contains either an instruction or data.  The first character of a label must be must be in the first column and must be a letter or an underscore (_) followed by a letter.  Labels can include up to 32 alphanumeric characters.

An instruction that executes in parallel with the previous instruction signifies this with parallel bars (||). This field is left blank for an instruction that does not execute in parallel with the previous instruction.

Every instruction in the C6x can execute conditionally.  There are five registers available for conditions: A1, A2, B0, B1, and B2.  If blank, the instruction always executes.  Conditions can take a form such as [A1] where the instruction will execute if A1 is not zero.  This can be handy for making loops were the counter is put in a register like A1 and is counted down to zero.  The condition is put on the branch instruction that branches back to the beginning of the loop.

Assembly code instructions are either directives or mnemonics.  An example directive is


.sect “ name” 
This creates a section of information (data or code).  Directives will be addressed later.
Mnemonics are the processor instructions.  Table 1 gives a list of the instructions for the C6201.

Table 1: 'C6201 Instruction Set by Category, taken from TMS320C6000 DSP Design Workshop
	Arithmetic
	Logical
	Bit Management
	Data Management
	Program Control

	BS
ADD
ADDA
ADDK
ADD2
MPY
MPYH
NEG
SMPY
SMPYH
SADD
SAT
SSUB
SUB
SUBA
SUBC
SUB2
ZERO
	AND
CMPEQ
CMPGT
CMPLT
NOT
OR
SHL
SHR
SSHL
XOR
	CLR
EXT
LMBD
NORM
SET
	LDB/H/W
MV
MVC
MVK
MVKL
MVKH
MVKLH
STB/H/W
	B
IDLE
NOP


Figure 2 shows the functional units of the C6x.  There are two sets of registers and two sets of functional units.  Given a certain instruction, it will only be able to execute on certain functional units.  See Table 2.
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Figure 2: Functional Units of the 'C6x, taken from SPRU198: TMS320C6000 Programmers' Guide

Table 2: C6701 Instructions by Functional Unit

	.S Unit
	.L Unit
	.M Unit
	.D Unit

	Fixed Point
	
	
	

	ADD
ADDK
ADD2
AND
B
CLR
EXT
MV
MVC
MVK
MVKL
MVKH

NEG
NOT 
OR
SET
SHL
SHR
SSHL
SUB
SUB2
XOR
ZERO
	ABS
ADD
AND
CMPEQ
CMPGT
CMPLT
LMBD
MV
NEG
NORM
NOT
OR
SADD
SAT
SSUB
SUB
SUBC
XOR
ZERO

	MPY
MPYH
MPYLH
MPYHL

SMPY
SMPYH
	ADD
ADDAB
(B/H/W)
LDB

(B/H/W)
MV

NEG
STB
(B/H/W) 
SUB
SUBAB 
(B/H/W) 
ZERO


	Floating Point
	
	
	

	ABSSP
ABSDP
CMPGTSP
CMPEQSP
CMPLTSP
CMPGTDP
CMPEQDP
CMPLTDP
RCPSP
RCPDP
RSQRSP
RSQRDP
SPDP
	ADDSP
ADDDP
SUBSP
SUBDP
INTSP
INTDP
SPINT
DPINT
SPRTUNC
DPTRUNC
DPSP

	ADDAD
LDDW
	MPYSP
MPYDP
MPYI
MPYID


All instructions require a destination operand and it must be in the same register file as one source operand.  Most instructions require one or two source operands.

A comment may begin in any column when preceded by a semicolon ( ; ). If a comment begins with an asterisk (* ) it must begin in the first column.

Memory Maps

Depending on the dip switches set on the EVM, the memory map can be one of two configurations.  See Figure 3 and Figure 4.
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Figure 3: Memory Map 0, taken from SPRU305 TMS320C6201/6701 Evaluation Module Technical Manual
[image: image4.png]External

Mooy Sao
SuriAddwss _EndAddross  Space (Byiss) _Doscripton
0 [T K tamalpogram memory (P
o000 ooaFFEFE A WS Resarved s V)
0400000 00FFFF ceo 20 sesam
oowooo  OIOFFFFE  CE0  eM-2K  Unussd
ouoono  owrerE  cel S Aenotvonous sxpansion memory
om0 oo0asF cer B pClsdtonmgisrs
ooonda omoRrEE cE1 ket Unsialable
oo on7ioaes 4 rarro
omiows omnieeee [T pv——,
oo on7zocor cer o Auocodecragises
omono o cal K16 Unsvalabe
om0 orrreeE cer 2K Aeserved
oo oweote  cel 32 OSPoomlssus egtars
oeoozo  orerFe LU v—
owswo  oweREFE cel o Resared
oteoooon  01BFFFEF A M el pergnerss
o0 ovFrFFEE A [T —
oo ozFreRE ce2 A SORAM ek 0) o otors s
o0 cereErEE ce2 ™ R
w0 owFFEEE oEs A SORAM k) o otors s
ouoon0  wFEEEEE cE ™ R
owooocn  TFFFFFEF A oM Resared
soooooon  saoorFeE A K inamol data memory (OM)
oo enaFFEFE A WG Resarved fuura OM)

sodoo0on_ FRFFFFFE A 204 Reserved





Figure 4: Memory Map 1, taken from SPRU305 TMS320C6201/6701 Evaluation Module Technical Manual
Linker Command Files and Sections

Figure 5 shows the software development flow for the C6x.  Usually you will start with C/C++ and assembly source files.  The C/C++ files are assembled into assembly code files.  The assembler generates COFF files that can be placed in different places in memory.  These COFF object files are then linked together by the linker to generate an executable COFF file.  The executable COFF file can be loaded onto the C6x or used in debugging tools.
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Figure 5: Software development flow, taken from SPRU186: TMS320C6000 Assembly Language Tools User’s Guide
The linker takes as input object files, command files, libraries, and partially linked files.  The command files are used to hold commands for the linker.  Within the command file the two directives discussed here are the MEMORY and SECTIONS directives. The MEMORY directive defines the target memory configuration and the SECTIONS directive controls how sections are built and allocated.  

Sections

The smallest unit of an object file is called a section. A section is a block of code or data that occupies contiguous space in the memory map with other sections. Each section of an object file is separate and distinct. COFF object files always contain three default sections:

.text section usually contains executable code

.data section usually contains initialized data

.bss section usually reserves space for uninitialized variables

In addition, the assembler and linker allow you to create, name, and link named sections that are used like the .data, .text, and .bss sections.

One of the linker’s functions is to relocate sections into the target system’s memory map; this function is called allocation. Because most systems contain several types of memory, using sections can help you use target memory more efficiently. All sections are independently relocatable; you can place any section into any allocated block of target memory. For example, you can define a section that contains an initialization routine and then allocate the routine into a portion of the memory map that contains ROM.

Code Composer Studio Project

Create a new project in Code Composer Studio (CCS) by selecting Project->New...  This will bring up a window that will look like Figure 6.  Type the name of your project in the Project Name field and it will add a folder with the same name in the Location field.  Leave everything else the same if you are planning to build a project for the 'C6701 EVM (be sure to have TMS320C67XX selected).  Click Finish and CCS will open your new project.  This will look like Figure 7.
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Figure 6: Project creation window
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Figure 7: Project window

In order to build a project you must have files in it.  To add files you must first create the files and save them.  Create a new assembly code file (*.asm), C code file (*.c) or command file (*.cmd) by selecting File->New->Source File.  When you save the file give it the correct extension.  Add the files to the project by selecting Project->Add Files To Project... and selecting the files.  You can see the files in your project by expanding the "+" signs.  All projects will need source files and a command file.  In subsequent labs you will see configuration files that generate command files for you.  In that case you will not need to include your own command file.

WARNING:  When you copy a project folder from one location to another, files that are in the project may be the files from the old location.  That is, CCS sometimes uses absolute referencing for project file names.  As an example, if you had a project in folder C:\ti\myprojects\test that contained the file C:\ti\myprojects\test\test.c and you copied the folder to C:\ti\myprojects\NEWtest and opened the project the file in the project would be C:\ti\myprojects\test\test.c, not the C:\ti\myprojects\NEWtest\test.c file you were expecting to use.  Be sure to check file names by right clicking on the file and selecting Properties.

Once you have all your files in your project you can build the project to produce the object file (*.out).  Select Project->Build to incrementally build the project or Project->Build All to rebuild all project files.  The Project->Build will only perform functions that are needed to bring the project up to date.  This option will usually be quicker than the Project->Build All option.

Now that the project has been built you must load the object file onto the target board or simulator.  Do this by selecting File->Load Program and selecting the *.out file.

With the project loaded you can step through the code (Debug->Step Into), view the registers (View->CPU Registers->Core Registers) and debug the results.  There are buttons on toolbars that you should become familiar with to aid in the debugging process.

Addressing Modes, Parallel Instructions, Conditional Operations, Delay Slots and Register File Cross Paths

There is more information related to these topics than can be put in this handout.  You should read the references above and also look at the "dsp6m01 architectural overview.ppt" and "dsp6m02 intro to pipeline.ppt" files of the TMS320C6000 DSP Design Workshop.  These files will show how to implement the code needed for this lab.

Laboratory

Part 1

· Make a new project titled lab1p1.

· Write a program in assembly that multiplies two constants together.  You will want to review the MVK and MPY instructions.  MVK is used to put the constants in a register and the MPY is used to multiply them.

· Write a linker command file that defines the MEMORY and SECTIONS directives for your program.  Note that the EVMs in the lab are set in memory map 1.  Use the following as a template.  Fill in where you see ?????.  The orgigin is the starting address of the memeory.

/* Memory Map 1 */

MEMORY 

{

   IPRAM                : origin = ?????   length = 0x00010000

   IDRAM                : origin = ?????   length = 0x00010000

   SBSRAM (RX)          : origin = ?????   length = 0x00030000

   SDRAM0_DATA_MEM (RW) : origin = ?????   length = 0x00400000

   SDRAM1_DATA_MEM (RW) : origin = ?????   length = 0x00400000

}

SECTIONS

{

        .text    > IPRAM

        .data    > IDRAM

        .bss     > IDRAM

        .cinit   > IDRAM

        .const   > IDRAM

        .far     > IDRAM

        .stack   > SDRAM0_DATA_MEM

        .cio     > IDRAM

        .sysmem  > SDRAM1_DATA_MEM

}

· Setup the program in Code Composer Studio and run it on the EVM, recording the values in the registers at each step as you single step through the program.  Be sure to note delay slots.

Part 2

· Make a new project titled lab1p2 and copy the command file from the first part.

· Write an assembly language program that performs a dot product of the following vectors using a loop that incorporates a conditional branch (The data for a and b should be stored in memory).

a = [1 2 3 4 5 6]

b = [6 5 4 3 2 1]
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To store the data in memory use the .data directive to specify what follows is data and the .word directive to specify a word (32-bits) of integer data.  For instance


.data

a:
.word
4

will put a 4 in memory in 4 bytes (word).  The label a can be used in the code.  It will give the memory location of the data 4.  If you use the .word directive you will need to use the LDW command to load a word of data.  If you use the .half directive you will need to use the LDH command to load a half word of data.

Use the ADD command to add the data, SUB to update a counter and a conditional B to perform the loop.

Part 3

· Make a new project titled lab1p3 and copy the command file from the first part.

· Write a third program that performs the same operation but uses parallel instructions and the register file cross path.  With the use of parallel instructions and the use of both register files the second program should take fewer instruction cycles.  Be sure to keep a loop in your program.  

· Setup the program in Code Composer Studio and run it on the EVM, counting the number of cycles required for the dot product in each case.  You can use the clock functionality in CCS.
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